How to Fix Google Cache Showing 404 Error For Your (or any other) Site

When you're building links or wanting to see what a specific page on your site looks like in Google cache, along with the cache date and see this 404 error from Google's cache, it can be concerning.

When it's happening for your own site, it can definitely put people into a quick panic, thinking that something is broken, all their SEO efforts are in vain, Google is going to de-index them, or any number of other things. I'll admit I had some of these thoughts when I first saw it on one of my sites as well.

Fear Not! I'm here to help you fix this Google Cache 404.

First, a couple things to consider:

  1. There is credible evidence it does not affect your ranking in any way. Theories around why this happens vary from "it is being updated" or "your site is cached only in http or https if you recently changed it" but the truth is no one outside the Google folks TRULY know why. But that doesn't matter,  because it does not impact your rankings. Thank you, John Mueller for being active on Reddit.
  2. This "fix" does not work 100% of the time, but it does work fairly often. 
  3. This is more of a small URL hack than an actual "fix" because you can't fix something on Google's server, but we can sometimes get around their bugs. 

There's 2 ways I have gotten around this, and they're listed below. I find the 2nd one to be more reliable and it seems to work even when the 1st one doesn't, or in combination with the 1st one. Play around with them and see what works for you.

Example Google Cache 404 Error

Let's pick on Moz, shall we? Mostly because they're a recognized name in SEO and if this is happening to them too and they still have plenty of SEO related terms that are ranking then it might help to convince you of the "it's OK just ignore it" mentality that is pretty much your only option in this case. 

A simple Google search for "moz" brings up their homepage as #1 - as you would expect. When I click the down arrow and the cache link, I'm greeted with the 404 error:

 

Here's One Fix:

The URL for this particular page that provides me this error is: 

https://webcache.googleusercontent.com/search?q=cache:0mHt2cKI_FIJ:https://moz.com/+&cd=1&hl=en&ct=clnk&gl=us

But by changing the URL slightly to remove the trailing slash and everything after it from moz.com so the URL becomes https://webcache.googleusercontent.com/search?q=cache:0mHt2cKI_FIJ:https://moz.com then the cache page loads just fine:

 

This is a pretty simple little hack. As I mentioned it doesn't work all the time (you can see it doesn't work on this page and a number of others for moz.com) but it does work fairly often so give it a try and see if it works for your particular situation. 

Here's Another Fix That Also Works, Sometimes

I find this "fix" to be the more reliable of the two and it's also another URL hack that seems to perhaps be related to http/https (see below why I think that). 

In this situation, this Moz community URL that doesn't work with the method above https://webcache.googleusercontent.com/search?q=cache:__NMvucZ8Z4J:https://moz.com/community/q/website-showing-404-error-in-google-cache

Does work with this other method. Basically all I did was remove the "https://" from the moz.com part of URL "q" variable so it becomes https://webcache.googleusercontent.com/search?q=cache:__NMvucZ8Z4J:moz.com/community/q/website-showing-404-error-in-google-cache&cd=15&hl=en&ct=clnk&gl=us

It also works with removing the extra query variables after the URL, 

https://webcache.googleusercontent.com/search?q=cache:__NMvucZ8Z4J:moz.com/community/q/website-showing-404-error-in-google-cache

The reason I suspect it has something to do with http/https is because if you just change it from https to http it also works.

https://webcache.googleusercontent.com/search?q=cache:0mHt2cKI_FIJ:http://moz.com/+&cd=1&hl=en&ct=clnk&gl=us

Some times you may have to add http:// or https:// to the URL if that isn't in there and the cache is giving you a 404. 

Did either of these work for you?

Let me know in the comments below. 

2 comments

  • I have been struggling with this for a while and been trying one of the hacks (with the query variables) but it only works some of the time. I tried both the xyz.x version and removing the http parts and both of those worked for the URL I tested it on. Thanks!

    Marcus
  • I just ran across another method that works sometimes. Strip out everything behind the cache string’s terminating colon and replace it with xyz.x – more info here: https://twitter.com/JohnMu/status/1049227580291862529

    Mika

Leave a comment

Name .
.
Message .

Please note, comments must be approved before they are published